Freeforumzone mobile

AIUTO COMBINAZIONE SE/E/CERT.VERT

  • Posts
  • OFFLINE
    LDexcel
    Post: 1
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/10/2019 11:59 AM
    Buongiorno a tutti,
    mi sono iscritto a questo Forum per un aiuto.
    Vi seguo spesso e grazie al Vs. supporto ad altri user, sono riuscito ad imparare formule non sapendo nulla di excel.
    Purtroppo girando qua e la non riesco a trovare un aiuto a quello che cerco, pertanto mi sono iscritto nel tentativo di trovare un aiuto per ciò che devo fare.
    Mi spiego:
    Vorrei avere una formula che mi mi copii il numero di ore contenuto in celle verticali se corrisponde un nome e una data.
    Dal file allegato, vorrei che in G3 si inserisca in automatico dalla TABELLA A le ore del personale.
    Spero di essermi spiegato e che possiate aiutarmi.
    Vi ringrazio anticipatamente e chiedo scusa in anticipo in caso di aver trasgredito in qualche maniera al regolamento del Forum.

    Grazie a tutti
  • OFFLINE
    locatevaresino
    Post: 2,158
    Registered in: 3/21/2008
    Location: LOCATE VARESINO
    Age: 71
    Veteran User
    2007 / 13
    00 9/10/2019 3:39 PM
    ciao

    dalla tua tabella mi sembra di capire che il risultato lo vuoi in I3 e non in G3 quindi in I3 metti questa formula

    =MATR.SOMMA.PRODOTTO(($A$2:$A$7=I$2)*($B$2:$B$7=$H3)*($C$2:$C$7))

    da trascinare a destra e in giu'

    Ps attenzione ai riferimenti assoluti e relativi
    riallego il tuo file


    Ciao da locate
    excel 2007 / 13
  • OFFLINE
    locatevaresino
    Post: 2,159
    Registered in: 3/21/2008
    Location: LOCATE VARESINO
    Age: 71
    Veteran User
    2007 / 13
    00 9/10/2019 3:42 PM
    riciao

    ho allegato un file senza la formula

    riallego il file con inserita questa

    Ciao da locate
    excel 2007 / 13
  • OFFLINE
    LDexcel
    Post: 1
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/10/2019 4:17 PM
    Perfetto!
    Io non so dove hai imparato, ma sei stato bravissimo!
    Grazie, grazie infinite!!!
    Sei stato davvero gentile e soprattutto molto in gamba!

    Grazie ancora
    [Edited by LDexcel 9/10/2019 5:11 PM]
  • OFFLINE
    LDexcel
    Post: 2
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/10/2019 5:46 PM
    Scusate ancora a tutti.
    La formula funziona; ma se incollo nomi diversi, cambiando i campi della formula, perchè non funziona più?
    Ho caricato il file.
    Fatemi sapere per favore.

    Grazie
    [Edited by LDexcel 9/10/2019 6:02 PM]
  • OFFLINE
    GiuseppeMN
    Post: 3,460
    Registered in: 4/3/2013
    Master User
    Excel 2000 - 2013
    00 9/10/2019 6:20 PM
    Buona sera, LDexcel.

    @LDexcel, scrive:


    ... se incollo nomi diversi, cambiando i campi della formula ...


    Non capisco cosa hai modificato. Puoi chiarire l'operazione che hai eseguito? Grazie.


    Giuseppe

    Windows XP - Excel 2000
    Windows 10 - Excel 2013
  • OFFLINE
    LDexcel
    Post: 3
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/10/2019 6:26 PM
    Ho allungato i 3 settori A - B - C.
    E ho modificato h3 in E3.
    Ho allegato immagine
  • OFFLINE
    locatevaresino
    Post: 2,160
    Registered in: 3/21/2008
    Location: LOCATE VARESINO
    Age: 71
    Veteran User
    2007 / 13
    00 9/10/2019 11:38 PM
    ciao

    devi allungare i riferimenti alle colonne di ricerca
    in F3 la seguente formula

    =MATR.SOMMA.PRODOTTO(($A$2:$A$10000=F$2)*($B$2:$B$10000=$E3)*($C$2:$C$10000))

    trascini in giu' e a destra

    Ps nelle formule i riferimenti sono molto importanti che siano questi
    normali relativi o assoluti ,, guardati help cercando le spiegazioni a questi

    allego sempre il tuo file con modifiche
    Ciao da locate
    excel 2007 / 13
  • OFFLINE
    LDexcel
    Post: 4
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/11/2019 8:46 AM
    Buongiorno, avevo già allungato i campi.
    Anche con il nuovo file, se incollo diverse date, nomi e ore non modifica il quadro delle presenze.
    Perchè???
    Vi allego il file.
    Spero possiate aiutarmi ancora.

    Grazie
  • OFFLINE
    LDexcel
    Post: 5
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/11/2019 9:09 AM
    Provando ad incollare i dati delle colonne A-B-C, ho notato che incollando nuovi dati in B-C non ci sono problemi; se copia nuove date (colonna A) la formula sballa e dà 0.
    Ho provato anche a cambiare la Categoria delle celle A ma niente.
    Spero possiate aiutarmi usando come riferimento la nuova tabella.

    Grazie
  • OFFLINE
    dodo47
    Post: 2,386
    Registered in: 4/6/2013
    Location: ROMA
    Age: 71
    Veteran User
    2010
    00 9/11/2019 10:02 AM
    Ciao
    la colonna A dove sono le date è "sporca" ... probabilmente il copiare genera problemi.

    Fai questa prova:
    in A5 scrivi manualmente 2/9/19...vedrai che in G5 otterrai il valore.

    Non sapendo cosa c'è nel documento dal quale copi, potresti in col. D che è vuota fare: =A2 * 1 e poi copiare i valori in A

    saluti




    Domenico
    Win 10 - Excel 2016
  • OFFLINE
    locatevaresino
    Post: 2,161
    Registered in: 3/21/2008
    Location: LOCATE VARESINO
    Age: 71
    Veteran User
    2007 / 13
    00 9/11/2019 10:10 AM
    ciao

    tu riporti date in colonna A non come data ma come testo

    ora le soluzioni sono due
    la prima e' utilizzare una colonna di appoggio utilizzare la D che e' libera e inserire in D2 la seguente formula
    =DATA.VALORE(A2) e trascinare in giu'
    apportare la modifica alla formula in F3
    =MATR.SOMMA.PRODOTTO(($D$2:$D$10000=F$2)*($B$2:$B$10000=$E3)*($C$2:$C$10000))

    la seconda e' scrivere le date da F2 a AI2 in formato testo
    cosa ho fatto
    in E2 ho messo la data del 31/8/19 in F2 la seguente formula che mi scrive le date in formato testo
    =TESTO($E$2+RIF.COLONNA(A$1);"gg/mm/aaaa")
    quindi rimane valida la formula in F3
    =MATR.SOMMA.PRODOTTO(($A$2:$A$10000=F$2)*($B$2:$B$10000=$E3)*($C$2:$C$10000))

    vedi esempi nei due file che ti posto

    Ciao da locate
    excel 2007 / 13
  • OFFLINE
    LDexcel
    Post: 6
    Registered in: 9/10/2019
    Age: 34
    Junior User
    2007
    00 9/13/2019 10:11 AM
    Grazie dell'aiuto a tutti ma sopratutto a Locate, veramente gentile e capace.

    GRAZIE