formula

Full Version   Print   Search   Utenti   Join     Share : FaceboolTwitter
gga46
00Tuesday, March 24, 2020 3:07 PM
Salve a tutti,

cortesemente cerco se esiste una formula
che concatena celle a 2 a 2 e trascinate a destra.
nell'allegato dovrebbe essere spiegato meglio la
mia richiesta.
cioè ho 5 celle A-B-C-D-E devo fare una concatenazione
di celle che nella formula può essere conta se oppure
concatena celle e le combini a 2 a 2 tutte e 5.
per esempio a-b cella in cella g7; a-c in cella h7 eccetera

allego il file e grazie per l'aiuto.
Xeroxs64
00Tuesday, March 24, 2020 7:00 PM
Ciao per il primo ambo hai =C7&"-"&D7 questa formula la trascini in basso
poi per il secondo la adatti alle varie celle e trascini sempre in basso, e cosi fino all'ultimo ambo o coppia di celle
gga46
00Tuesday, March 24, 2020 8:23 PM
Salve xerox64

grazie per l'intervento,
ho spiegato nell'allegato cosa mi tocca fare
ora fatto per 5 celle mi sviluppo su 10 celle
e il problema non c'è.
Poniamo di avere 10 celle da combinare 2 a 2
tenuto conto che la prima cella deve abbinarsi
alla 10 che combinate tutte fra esse ci sono 100
combinazioni.
Chiedevo se si potesse risolvere con una supeformula,
ammesso che esista.

ciao
Xeroxs64
00Wednesday, March 25, 2020 6:24 AM
Non so se si possa fare con una formula ciò che chiedi, Forse con VBA ma non sono ancora in grado di farlo, oppure se hai esigenze divesre Ti crei un range fisso come la tua tabella estrazione settimanale, tanto se cambi data estrazione non devi più fare i calcoli le formule messe li aggiornano, altrimenti Ti crei una macro con la registrazione.
gga46
00Wednesday, March 25, 2020 10:41 AM
Salve,

xeroxes non avrei capito la tabella come impostarla

cio
Xeroxs64
00Wednesday, March 25, 2020 11:25 AM
Ciao, Ti ho aggiunto la cartella ambi con le tabelle quella degli ambi ci sono già le formule
se nell'estrazione cambi i valori nella tabella ambi tutto si aggiorna in automatico.

Devi solo riportare le estrazioni che ti interessano
gga46
00Wednesday, March 25, 2020 12:42 PM
OK XEROXES,

ti ringrazio della risposta,
cmq non era questo che volevo,
quei dati messi lì sono puramente casuali.
La richiesta è data dal fatto che spesso
ricorro nella richiesta fatta inizialmente
ma parlo perchè faccio e rifaccio sempre dei dati
in più fogli con impostazioni di colonne e
righe diverse.

Ciao
cromagno
00Wednesday, March 25, 2020 1:10 PM
Ciao,
puoi sfruttare la tabella proposta da @Xeror64 ( [SM=g27811] ) ed in cella J6 (da copiare poi a destra ed in basso per tutta la tabella) usare la formula:
=INDICE($C6:$G6;SINISTRA(J$4;1))&"_"&INDICE($C6:$G6;DESTRA(J$4;1))
locatevaresino
00Wednesday, March 25, 2020 1:25 PM
ciao

un'altra alternativa e' una udf in vba
da inserire in un modulo

Option Explicit
Public Function Accoppia(ByVal Ncelle As Range, ByVal Nsec As Long) As String
Dim i As Long, o As Long
Dim celle() As String
Dim conta As Long
Dim N_celle As Variant
Dim Stringa As String
Dim A1 As String, A2 As String
conta = 0
Stringa = ""
For Each N_celle In Ncelle
Stringa = Stringa & N_celle & " "
Next
celle = Split(Trim(Stringa), " ")
For i = LBound(celle) To UBound(celle)
A1 = celle(i)
For o = i + 1 To UBound(celle)
A2 = celle(o)
conta = conta + 1
If conta >= Nsec Then GoTo fine
Next o
Next i
fine:
Accoppia = A1 & "_" & A2
End Function

nel tuo caso da inserire in
I7 =accoppia($C7:$G7;RIF.COLONNA(A1))
trascini a destra e in giu' fino a dove ti serve

PS o dimenticato il tuo file
cromagno
00Wednesday, March 25, 2020 1:52 PM
Re:
Una variante rispetto alla formula proposta prima (senza appoggi)...

@gga46
nel tuo file, in cella I7 (da copiare poi a destra ed in basso):
=INDICE($C7:$G7;SCEGLI(RIF.COLONNA(A1);1;1;1;1;2;2;2;3;3;4))&"_"&INDICE($C7:$G7;SCEGLI(RIF.COLONNA(A1);2;3;4;5;3;4;5;4;5;5))
gga46
00Wednesday, March 25, 2020 2:01 PM
Salve Locatevaresino,

non so come ringraziarti perchè mi hai
risolto diversissime richieste.

VERY GOOD.

Grazie
gga46
00Wednesday, March 25, 2020 2:06 PM
Salve cromagno,

nonostante Locatevaresino mi ha risolto
il problema e poichè hai cercato di aiutarmi
volevo sapere perchè la tua formula mi da
VALORE

Non ho fatto altro che copiare ed incollare
la formula dove mi hai detto.

ciao
gga46
00Wednesday, March 25, 2020 2:10 PM
OK cromagno,

la seconda formula funziona
solo che ha sempre bisogno
dell'appoggio di rigo 4.
E' così?.

Ciao e grazie cmq
cromagno
00Wednesday, March 25, 2020 2:14 PM
La prima formula la devi usare nella tabella di @Xerox
La seconda formula (quella con la funzione SCEGLI) la devi usare nella TUA tabella e non ha bisogno di "appoggi"
locatevaresino
00Wednesday, March 25, 2020 3:40 PM
riciao

in attesa de COVID19 una semplice modifica alla UDF per non scrivere piu' anche se trasciniamo piu' oltre le combinazioni
da sostituire a quella di prima


Option Explicit
Public Function Accoppia(ByVal Ncelle As Range, ByVal Nsec As Long) As String
Dim i As Long, o As Long
Dim celle() As String
Dim conta As Long
Dim N_celle As Variant
Dim Stringa As String
Dim A1 As String, A2 As String
conta = 0
Stringa = ""
For Each N_celle In Ncelle
Stringa = Stringa & N_celle & " "
Next
celle = Split(Trim(Stringa), " ")
If Nsec > Application.Combin(UBound(celle) + 1, 2) Then
Accoppia = ""
Exit Function
End If
For i = LBound(celle) To UBound(celle)
A1 = celle(i)
For o = i + 1 To UBound(celle)
A2 = celle(o)
conta = conta + 1
If conta >= Nsec Then GoTo fine
Next o
Next i
fine:
Accoppia = A1 & "_" & A2
End Function


Xeroxs64
00Thursday, March 26, 2020 7:22 AM
Ciao a Tutti,
Volevo capire come generare questa ultima UDF non ci riesco o non ho compreso il suo impiego.

Grazie
gga46
00Thursday, March 26, 2020 9:53 AM
Salve,

aspe Cromagno,

volevo chiederti
formula eccezionale per cosa faccio io,

fermi restando che la seconda formula agganci
e combina 2 celle, che combina le 2 celle
nella tua formula con scegli vorrei utilizzare
meglio inserire questo calcolo ma il mio quesito
vale come uno degli esempi dove poter inserire anche
sempre come esempio un conta.se se presente i
numeri che cerco e quindi trascinarle,

=SE(RADQ(SOMMA.Q.DIFF(A1;B1))>45;90-RADQ(SOMMA.Q.DIFF(A1;B1));RADQ(SOMMA.Q.DIFF(A1;B1)))

Puoi utilizzare sempre per i dati il file allegato.

Spero di essermi spiegato

Ciao
gga46
00Thursday, March 26, 2020 9:58 AM
Ciao xerox,

per fare funzionare la UDF
devi usare questa formula
naturalmente cambiare i riferimenti di cella
a seconda dove la metti:

=accoppia($C7:$G7;RIF.COLONNA(A1))

By Locatevaresino

Ciao
Xeroxs64
00Thursday, March 26, 2020 11:01 AM
Ok Grazie
cromagno
00Thursday, March 26, 2020 3:46 PM
Re:
gga46, 26/03/2020 09:53:

Salve,

aspe Cromagno,

volevo chiederti
formula eccezionale per cosa faccio io,

fermi restando che la seconda formula agganci
e combina 2 celle, che combina le 2 celle
nella tua formula con scegli vorrei utilizzare
meglio inserire questo calcolo ma il mio quesito
vale come uno degli esempi dove poter inserire anche
sempre come esempio un conta.se se presente i
numeri che cerco e quindi trascinarle,

=SE(RADQ(SOMMA.Q.DIFF(A1;B1))>45;90-RADQ(SOMMA.Q.DIFF(A1;B1));RADQ(SOMMA.Q.DIFF(A1;B1)))

Puoi utilizzare sempre per i dati il file allegato.

Spero di essermi spiegato

Ciao



Ciao,
mi spiace ma non ho capito nulla [SM=x423023]
gga46
00Thursday, March 26, 2020 10:54 PM

Non cè problema
ho dato una spiegazione troppo veloce

Partiamo sempre sui 5 numeri del file allegato
da colonna E a colonna i devo trasscinare
la formula

=SE(RADQ(SOMMA.Q.DIFF(E6;F6))>45;90-RADQ(SOMMA.Q.DIFF(E6;F6));RADQ(SOMMA.Q.DIFF(E6;F6)))

TRASCINO A DESTRA

=SE(RADQ(SOMMA.Q.DIFF(E6;G6))>45;90-RADQ(SOMMA.Q.DIFF(E6;G6));RADQ(SOMMA.Q.DIFF(E6;G6)))

SE ALLA COLONNA E NON USO IL $ OTTENGO LA F

ORA NELLA TUA FORMULA SCEGLI VORREI INSERIRE
NON SOSTITUIRE LA MIA
Questa è la versione 'lo-fi' del Forum Per visualizzare la versione completa click here
Tutti gli orari sono GMT+01:00. Adesso sono le 7:08 PM.
Copyright © 2000-2020 FFZ srl - www.freeforumzone.com