Previous page | 1 | Next page

Excel formula fuori 90

Last Update: 2/13/2024 11:41 AM
Author
Vote | Print | Email Notification    
Post: 100
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 11:58 AM
 
Modify
 
Delete
 
Quote

Ciao, Ho questa formula funzionante per quanto riguarda la somma in verticale.

=SE(O(MATR.SOMMA.PRODOTTO((ASS(D$5:D$15+D5)=$AE$10)*(RIF.RIGA(D$5:D$15)<>RIF.RIGA(D5)));MATR.SOMMA.PRODOTTO((ASS(D$5:D$15+D5)-90=$AE$10)*(RIF.RIGA(D$5:D$15)<>RIF.RIGA(D5))));1;0)

A me serve la stessa cosa ma in orizzontale.

ho fatto la modifica da rif riga a rif colonna però non funziona sbaglio qualcosa ?

=SE(O(MATR.SOMMA.PRODOTTO((ASS(D$5:H$5+D5)=$AE$10)*(RIF.COLONNA(D$5:H$5)<>RIF.COLONNA(D5)));MATR.SOMMA.PRODOTTO((ASS(D$5:H$5+D5)-90=$AE$10)*(RIF.COLONNA(D$5:H$5)<>RIF.COLONNA(D5))));1;0)

Post: 3,239
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 1:01 PM
 
Modify
 
Delete
 
Quote

ciao
io se non vedo la struttura difficilmente
riesco a capire...è un mio limite lo so
ma almeno un'immagine dovrei vederla
Post: 100
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 1:51 PM
 
Modify
 
Delete
 
Quote

Ciao Federico. Eccoti la struttura
ho evidenziato a mano libera in rosso una coppia di nr, un caso sulla ruota di Napoli come vedi se sommi 66+69= 135-90 =45
Allego file
Post: 3,242
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 6:28 PM
 
Modify
 
Delete
 
Quote

ciao
la formula funziona
ma nei primi 5 numeri non trova riscontro
prova a scrivere
47 88 66 90 28

ma alla fine cosa deve fare la formula
Post: 101
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 6:35 PM
 
Modify
 
Delete
 
Quote

Ok allora si passa alle altre estrazioni
fin quando si trova la coppia che corrisponde alla somma 45.
Che modifica hai fatto ?
Mi riferisco alla ricerca in Orizzontale D5:H5.
Post: 3,243
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 6:40 PM
 
Modify
 
Delete
 
Quote

nessuna modifica ho solo guardato il risultato degli O()
visto che dava
FALSO
FALSO
ho cambiato un paio di numeri

Post: 3,244
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 6:50 PM
 
Modify
 
Delete
 
Quote

ciao
mi dici in parole tue
cosa devi fare?
devi trovare il 45 in base a che calcolo
Post: 102
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 6:59 PM
 
Modify
 
Delete
 
Quote

In pratica la formula deve trovare una coppia tra i cinque estratto che dia somma 45 se per esempio la somma è 135 si fa il fuori 90 e diventa 45.
La formula che ho riportato all'inizio funziona benissimo, unica cosa che è stata fatta per la ricerca in verticale.
La mia domanda è come farla operare in orizzontale ?

NB: In AE10 metto io la somma infatti nella stringa della formula c'è AE10.
[Edited by saxson 2/12/2024 7:01 PM]
Post: 3,245
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 7:06 PM
 
Modify
 
Delete
 
Quote

ciao
funziona ma non hai nessuna coppia che sommata dia 45
neanche con -90
ora vedo se riesco a divertirmi
[Edited by federico460 2/12/2024 7:07 PM]
Post: 103
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 7:11 PM
 
Modify
 
Delete
 
Quote

Se provi spostandoti con il cursore dellle estrazioni alla data del 20/1/24 sulla ruota di Napoli Troverai questa cinquina sortita 60-66-77-69-13
la coppia 66+69 ha un totale di 135-90 = 45.
Post: 104
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 7:11 PM
 
Modify
 
Delete
 
Quote

Se provi spostandoti con il cursore dellle estrazioni alla data del 20/1/24 sulla ruota di Napoli Troverai questa cinquina sortita 60-66-77-69-13
la coppia 66+69 ha un totale di 135-90 = 45.
Post: 3,246
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 7:57 PM
 
Modify
 
Delete
 
Quote

ciao
seleziona la tabella da D5 a H15
metti questa in formattazione condizionale
=MATR.SOMMA.PRODOTTO((ASS((D5+$D5:$H5)-90)=$AE$10)*SE(D5=45;CONTA.SE($D5:$H5;$AE$10)>1;1))[/COLORE
[Edited by federico460 2/12/2024 7:59 PM]
Post: 105
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 8:10 PM
 
Modify
 
Delete
 
Quote

Ottimo funziona alla grande
grazie mille................................
Post: 3,247
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/12/2024 8:29 PM
 
Modify
 
Delete
 
Quote

ciao
ho dimenticato di cambiare un 45 con la cella dopo il SE(
*SE(D5=45
fallo tu
[Edited by federico460 2/12/2024 8:30 PM]
Post: 106
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/12/2024 11:34 PM
 
Modify
 
Delete
 
Quote

OK Grazie
A me sembra che funzioni così come l'avevi impostata
l'ho messa giù cosi : =MATR.SOMMA.PRODOTTO((ASS((D5+$D5:$H5)-90)=$AE$10)*SE(D5=45;CONTA.SE($D5:$H5;$AE$10)>1;1))
ho dovuto eliminare questo [/COLORE perchè non funzionava.
Eventualmente appena hai un'attimo se la metti completa, Grazie
[Edited by saxson 2/12/2024 11:41 PM]
Post: 3,248
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/13/2024 2:16 AM
 
Modify
 
Delete
 
Quote

ciao
COLORE
mi è rimasto da un copia incolla
e non centra con la formula

devi mettere la cella anche nel SE

ora funziona perchè c'è scritto 45 nella cella ma se cambi numero(cosa che teoricamente non dovresti fare)
sballa la formula.
Post: 107
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/13/2024 9:56 AM
 
Modify
 
Delete
 
Quote

Così

=MATR.SOMMA.PRODOTTO((ASS((D5+$D5:$H5)-90)=$AE$10)*SE(D5=$AE$10;CONTA.SE($D5:$H5;$AE$10)>1;1))

Però mi trova solo la somma 90
Post: 3,249
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/13/2024 10:29 AM
 
Modify
 
Delete
 
Quote

ciao
90?

ti trova tutti gli ambi fanno 45

[Edited by federico460 2/13/2024 11:15 AM]
Post: 108
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/13/2024 11:18 AM
 
Modify
 
Delete
 
Quote

Ciao
No, dopo aver fatto la modifica nella stringa, nella speranza di aver compreso la tua indicazione
non trova la somma 45 ma 90.
Sicuramente ho sbagliato io qualcosa, infatti dovrebbe variare la ricerca della somma in base a quello che io metto nella cella AE10.
Se invece lascio così come lo hai fatto tu :
=MATR.SOMMA.PRODOTTO((ASS((D5+$D5:$H5)-90)=$AE$10)*SE(D5=45;CONTA.SE($D5:$H5;$AE$10)>1;1))
Funziona alla perfezione trovando la somma 45. Vabbè a limite lascio così e se mi serve trovare altre somme vado a modificare quel 45.
Cioè : )*SE(D5=45
Grazie veramente della tua gentilezza e disponibilità
Post: 3,250
Registered in: 10/10/2013
Location: VICENZA
Age: 68
Master User
365
OFFLINE
2/13/2024 11:26 AM
 
Modify
 
Delete
 
Quote

ciao

se hai nella cella 45 il problema non dovrebbe porsi.
ma comunque si va lasciato il 45
Post: 109
Registered in: 1/4/2004
Location: TREVISO
Junior User
2007
OFFLINE
2/13/2024 11:41 AM
 
Modify
 
Delete
 
Quote

Ok nuovamente grazie
Vote:
Admin Thread: | Close | Move | Delete | Modify | Email Notification Previous page | 1 | Next page
New Thread
 | 
Reply
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Feed | Forum | Bacheca | Album | Users | Search | Log In | Register | Admin
Tutti gli orari sono GMT+01:00. Adesso sono le 2:34 PM. : Printable | Mobile | Regolamento | Privacy
FreeForumZone [v.6.1] - Copyright © 2000-2024 FFZ srl - www.freeforumzone.com