Previous page | 1 | Next page
Facebook  

Funzione CERCA(valore, vettore, [risultato]) su valori non ordinati

Last Update: 3/24/2020 11:54 AM
Author
Print | Email Notification    
Post: 6
Registered in: 1/13/2019
Location: LESMO
Age: 72
Junior User
2013
OFFLINE
3/24/2020 11:11 AM
 
Modify
 
Delete
 
Quote

La funzione CERCA(valore, vettore, [risultato]) deve operare su un vettore ordinato, se no non fornisce risultato corretto (vedi cella A2 nell'esempio allegato).
Per ovviare a ciò, io usualmente creo una macro (nell'esempio macro COPIAeORDINA con pulsante blu) che mi copia i valori di vettore e risultato in altra posizione (F2:G8) e quindi li ordina secondo valori crescenti di vettore (F2:F18). La funzione CERCA (in A4) utilizza come vettore le celle ordinate (F2:F8) e fornisce quindi un risultato corretto.

Se siete così gentili da darmi una risposta, la mia domanda é: esiste un metodo diverso e più semplice per ottenere il risultato, anche con uso di Vba, per poter avere il risultato corretto, senza dover copiare i valori di vettore e risultato?

Grazie per il Vostro aiuto ed un saluto,
Alberto
Post: 2,595
Registered in: 4/6/2013
Location: ROMA
Age: 72
Veteran User
2010
OFFLINE
3/24/2020 11:37 AM
 
Modify
 
Delete
 
Quote

ciao
se i valori dei vettori sono univoci, perchè non usi il cerca.vert ?

=CERCA.VERT(B2;C2:D8;2;FALSO)

saluti




[Edited by dodo47 3/24/2020 11:39 AM]
Domenico
Win 10 - Excel 2016
Post: 7
Registered in: 1/13/2019
Location: LESMO
Age: 72
Junior User
2013
OFFLINE
3/24/2020 11:52 AM
 
Modify
 
Delete
 
Quote

Grazie dodo47, perfetto! Spaevo che doveva esserci una soluzione ma non ci arrivavo.
Vedo che siamo coetanei: grande annata il 47!
Un saluto, Alberto
Post: 2,596
Registered in: 4/6/2013
Location: ROMA
Age: 72
Veteran User
2010
OFFLINE
3/24/2020 11:54 AM
 
Modify
 
Delete
 
Quote

Re:
LuponeAlberto, 24/03/2020 11:52:

Grazie dodo47, perfetto! Spaevo che doveva esserci una soluzione ma non ci arrivavo.
Vedo che siamo coetanei: grande annata il 47!
Un saluto, Alberto



si...ma molto lontana!!!

cari saluti




Domenico
Win 10 - Excel 2016
Admin Thread: | Close | Move | Delete | Modify | Email Notification Previous page | 1 | Next page
New Thread
 | 
Reply
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Users | Search | Log In | Register | Admin
Tutti gli orari sono GMT+01:00. Adesso sono le 2:11 PM. : Printable | Mobile | Regolamento | Privacy
FreeForumZone [v.5.1] - Copyright © 2000-2020 FFZ srl - www.freeforumzone.com