Previous page | 1 | Next page
Facebook  

Conteggio presenze annuali quadrimestre e mensili per un determinato periodo

Last Update: 11/8/2019 8:51 AM
Author
Print | Email Notification    
Post: 1
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/3/2019 3:28 AM
 
Modify
 
Delete
 
Quote

Buonasera a tutti come da titolo stavo provando a ricavare il conteggio delle presenze in un determinato range(anno, quadrimestre e mese) per capire quanti utenti sono stati presenti in quel periodo. Ho data di inizio programma e data di fine. Le domande che vorrei porre ad excel sono: quanti utenti ho avuto in quel determinato anno? Quanti utenti di quell'anno erano presenti nel primo, secondo e terzo quadrimestre? Come erano distribuiti gli utenti mensilmente?Se qualcuno potesse aiutarmi a capire dove sbaglio gliene sarei grato. Grazie mille in anticipo
Post: 705
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/3/2019 9:39 PM
 
Modify
 
Delete
 
Quote

Ciao,
potresti scrivere i risultati che ti aspetteresti per "Persone presenti in ogni mese" e per "Persone presenti nel 1,2 e 3 quadrimestre" ?!?
Formule a parte, a me i risultati sembrano corretti.


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 1
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/3/2019 10:09 PM
 
Modify
 
Delete
 
Quote

Quadrimestre
Buonasera, allora per quanto riguarda i conteggi mensili penso di aver risolto. Per quanto riguarda i quadrimestre il problema si pone quando ho due utenze per esempio:

Utenti. Inizio. Fine
#1 1/5/2015 | 5/5/2015
#2. 1/6/2015. | 6/6/2015

Con queste due date dovrei ottenere sotto il secondo quadrimestre il numero 2 invece ottengo 1.

Per quadrimestre intendo quanti utenti erano presenti esempio dal 1/1/2015 al 30/4/2015
Post: 2
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/3/2019 10:13 PM
 
Modify
 
Delete
 
Quote

Questa è un esempio
Post: 706
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/3/2019 10:35 PM
 
Modify
 
Delete
 
Quote

ok, ma nel file che hai allegato quali sono i risultati che non tornano?


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 3
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/3/2019 10:40 PM
 
Modify
 
Delete
 
Quote

I quadrimestri. Ti allego il file così forse si capisce meglio
Post: 707
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/4/2019 12:43 AM
 
Modify
 
Delete
 
Quote

Ciao,
se ho capito bene, in cella E5 (da copiare poi a destra):
=SOMMA(--(MATR.PRODOTTO(((DATA($E$1;RIF.COLONNA(SCARTO(A1;;;;4));1)>=$B$2:$B$8)*(DATA($E$1;RIF.COLONNA(SCARTO(A1;;;;4));1)<=$C$2:$C$8));RIF.RIGA($A$1:$A$4)^0)>0))


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 4
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 2:28 AM
 
Modify
 
Delete
 
Quote

WOW questa è perfetta
L'ho testata velocemente ma sembra funzionare molto bene. Interessante lo scarto. Volevo chiederti: questa formula si potrebbe riassumere anche con MATR.SOMMA.PRODOTTO così è compatibile anche con google sheet? Grazie mille molto intelligente
Post: 708
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/4/2019 3:07 AM
 
Modify
 
Delete
 
Quote

in che senso riassumere?
MATR.PRODOTTO é diversa da MATR.SOMMA.PRODOTTO...


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 5
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 3:26 AM
 
Modify
 
Delete
 
Quote

Pensavo avendo usato somma più MATR PRODOTTO si potesse unificare in MATR.SOMMA.PRODOTTO. Ti Allego il file, potresti gentilmente spiegarmi dove sbaglio? Prima la tua formula funzionava ora ho fatto solo degli aggiustamenti ma mi sa che ho perso qualcosa per strada
Post: 710
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/4/2019 4:27 AM
 
Modify
 
Delete
 
Quote

Ho eliminato la risposta di prima...avevo frainteso.
L'errore sta nel fatto che avevo considerato la data da testare solo con il primo giorno:
DATA($E$2;RIF.COLONNA(SCARTO(A1;;;;4));1)

prova a modificare la formula in cella E6 in questo modo:
=SOMMA(--(MATR.PRODOTTO(((DATA($E$2;RIF.COLONNA(SCARTO(A1;;;;4));GIORNO($B$3:$B$8))>=$B$3:$B$8)*(DATA($E$2;RIF.COLONNA(SCARTO(A1;;;;4));GIORNO($C$3:$C$8))<=$C$3:$C$8));RIF.RIGA($A$1:$A$4)^0)>0))
[Edited by cromagno 11/4/2019 4:27 AM]


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 6
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 7:52 AM
 
Modify
 
Delete
 
Quote

WOW semplicemente perfetto. Non ci sarei mai arrivato. Grazie mille, veramente. Ultima cosa. Sai come posso renderle compatibili con i fogli di google? Quest'ultima formula è perfetta su excel ma a google non va giù. Sai se c'è un modo? Grazie ancora
Post: 711
Registered in: 8/2/2015
Senior User
Excel 2013
OFFLINE
11/4/2019 8:10 AM
 
Modify
 
Delete
 
Quote

Non saprei... non so quali funzioni accetti "fogli google", mai usato.


"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Post: 7
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 8:13 AM
 
Modify
 
Delete
 
Quote

Ok non c'è problema hai già fatto veramente tanto con quella formula. Ti ringrazio molto
Post: 8
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 8:17 AM
 
Modify
 
Delete
 
Quote

Condivido con tutti il file funzionale. Magari può essere d'aiuto a qualcuno.
Post: 2,186
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
11/4/2019 11:57 AM
 
Modify
 
Delete
 
Quote

ciao

ieri sera ,stavo scrivendo ma mi sono dovuto assentare

comunque possiamo utilizzare le date , non come date che vediamo ma con il suo valore numerico, essendo che excel e penso tutti gli altri database utilizzino questo metodo
quindi possiamo creare un periodo di ricerca creando valori numerici tramite date

esempio in base al primo file postato
periodo gen-dic 2015
=MATR.SOMMA.PRODOTTO(($B$2:$B$8<=DATA($E$1;12;31))*($C$2:$C$8>=DATA($E$1;1;1)))
per gen-apr 2015
=MATR.SOMMA.PRODOTTO(($B$2:$B$8<=FINE.MESE(DATA($E$1;4;1);0))*($C$2:$C$8>=DATA($E$1;1;1)))
mag-ago
=MATR.SOMMA.PRODOTTO(($B$2:$B$8<=FINE.MESE(DATA($E$1;8;1);0))*($C$2:$C$8>=DATA($E$1;5;1)))
set-dic
=MATR.SOMMA.PRODOTTO(($B$2:$B$8<=FINE.MESE(DATA($E$1;12;1);0))*($C$2:$C$8>=DATA($E$1;9;1)))
per i mesi ho inserito nella formula anche un riferimento a colonna
in E4 =MATR.SOMMA.PRODOTTO(($B$2:$B$8<=FINE.MESE(DATA($E$1;RIF.COLONNA(A1);1);0))*($C$2:$C$8>=DATA($E$1;RIF.COLONNA(A1);1)))
trascinato fino a dicenbre

per il secondo file
periodo gen-apr
=MATR.SOMMA.PRODOTTO(($B$2:$B$4<=FINE.MESE(DATA($E$1;4;1);0))*($C$2:$C$4>=DATA($E$1;1;1)))
riportando dati come sopra periodo mag-ago set-dic


riallego i due file con formule inserite per controllo
Ciao da locate
excel 2007 / 13
Post: 9
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 2:20 PM
 
Modify
 
Delete
 
Quote

Anche questa molto buona e dovrebbe funzionare anche su Google sheet. Dopo con calma verifico. Mi avete dato dei grandi spunti su come utilizzare le matrici e delle belle formule da analizzare e studiare. Vi ringrazio ancora. Io non ci sarei proprio arrivato. 😀
Post: 2,187
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
11/4/2019 3:57 PM
 
Modify
 
Delete
 
Quote

ciao

google sheets

funzioni presenti

Matrice MATR.SOMMA.PRODOTTO MATR.SOMMA.PRODOTTO(matrice1; matrice2) Calcola la somma dei prodotti delle voci corrispondenti in due matrici o intervalli di uguale dimensione. Ulteriori informazioni

Data DATA DATA(anno; mese; giorno) Converte il giorno, mese e anno specificati in una data. Ulteriori informazioni

Data FINE.MESE FINE.MESE(data_iniziale; mesi) Restituisce la data dell'ultimo giorno di un mese che cade un determinato numero di mesi prima o dopo un'altra data. Ulteriori informazio

Ricerca RIF.COLONNA RIF.COLONNA(riferimento_cella) Restituisce il numero di colonna di una cella specificata, con "A=1". Ulteriori informazioni


Quindi ai tutto quello che ti serve
[Edited by locatevaresino 11/4/2019 3:59 PM]
Ciao da locate
excel 2007 / 13
Post: 10
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 4:09 PM
 
Modify
 
Delete
 
Quote

Stavo proprio verificando questi parametri. Più tardi lo importo e vi faccio sapere. Intanto lo sto popolando un pò con dei dati di prova
Post: 11
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 6:16 PM
 
Modify
 
Delete
 
Quote

Funziona perfettamente anche su google. Mi chiedo se è possibile inserire delle condizioni sia nei mesi che negli anni che nei quadrimestre. Tipo: se anno di inizio esiste ma anno di fine no allora calcola la data odierna come anno di fine. Non capisco in quale parte della formula inserirlo.
Post: 2,188
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
11/4/2019 7:34 PM
 
Modify
 
Delete
 
Quote

ciao

con VBA non sarebbe un problema, mentre sul foglio devi utilizzare una colonna di appoggio e fare riferimento a questa come fine ,con alcuni accorgimenti per calcolare il tutto
servono 2 se() annidati
ti ripasso il tuo file con questa inserita e le formule corrette

si intende che la colonna di appoggio quella in rosso va nascosta

Ciao da locate
excel 2007 / 13
Post: 12
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/4/2019 10:52 PM
 
Modify
 
Delete
 
Quote

Buona soluzione. Quindi non è possibile integrarlo alla formula senza usare la colonna nascosta? Solo curiosità
Post: 2,189
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
11/4/2019 11:58 PM
 
Modify
 
Delete
 
Quote

ciao

dobbiamo per forza usare una colonna di appoggio per il valore di fine
quindi assolutamente nelle celle dobbiamo avere un valore ,vedi che riporto il valore 1 quando la cella di inizio e' vuota

come detto se usassimo VBA questo valore lo possiamo creare tramite una variabile e passarlo al calcolo

quindi ricapitolando utilizza la colonna di appoggio , intanto dopo quando ai inserito le formule la nascondi e non se ne parla piu'
e come quella cosa che serve ma non si vede ( ce' ma non ce' )

PS colonne di appoggio se ne usano moltissime quando non si puo' utilizzare VBA

Ciao da locate
excel 2007 / 13
Post: 13
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/6/2019 4:01 PM
 
Modify
 
Delete
 
Quote

=MATR.SOMMA.PRODOTTO(($B$2:$B$8<=DATA($E$1;12;31))*($C$2:$C$8>=DATA($E$1;1;1)))

Utilizzo appunto questa formula che mi avete suggerito per calcolare quanti utenti sono presenti nello specifico anno. Posso partire da questa per calcolare anche la media delle presenze fatte nello stesso anno. numero di giorni totale per quell'anno diviso numero utenti totale per quell'anno?

Allego il file così forse si capisce. Se sono offtopic apro un altra discussione.
Post: 2,191
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
11/6/2019 7:49 PM
 
Modify
 
Delete
 
Quote

ciao

si quella e' valida, ma come detto in precedenza devi calcolare i giorni durante l'anno quindi devi creare una colonna di appoggio o varie colonne per quante te ne servono

faccio prima a passarti sempre il tuo file con inserita questa per il calcolo Anno e come e' strutturato il tutto

PS se vuoi calcolare i quadrimestri e i mesi ti devi creare colonne di appoggio anche per questi


ciao mi sono accorto che nella formula e' presente un dato sbagliati ho lasciato 1 dic al posto di 31 correggi te la formula in Q2
[Edited by locatevaresino 11/7/2019 12:43 AM]
Ciao da locate
excel 2007 / 13
Post: 14
Registered in: 11/3/2019
Age: 35
Junior User
2019Mac
OFFLINE
11/8/2019 8:51 AM
 
Modify
 
Delete
 
Quote

Grazie. Ora vedo di cambiare data. Ancora mille grazie
Admin Thread: | Close | Move | Delete | Modify | Email Notification Previous page | 1 | Next page
New Thread
 | 
Reply
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Users | Search | Log In | Register | Admin
Tutti gli orari sono GMT+01:00. Adesso sono le 9:47 PM. : Printable | Mobile | Regolamento | Privacy
FreeForumZone [v.5.1] - Copyright © 2000-2020 FFZ srl - www.freeforumzone.com