Previous page | 1 | Next page
Facebook  

Excel 365: stesso valore in colonna in righe diverse

Last Update: 7/30/2019 10:35 AM
Author
Print | Email Notification    
Post: 4
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/29/2019 4:37 PM
 
Modify
 
Delete
 
Quote

Buongiorno a tutti, esperti di excel
Ho un grande excel e la prima colonna a volte si ripete con contatti diversi. Vorrei raggruppare l'azienda e mettere i contatti e email in colonne diverse.
E' possibile fare questo con una funzione di excel senza scrivere codice VBA? Grazie a tutti per le risposte

Azienda Contatto Email
Fiat Paolo rossi prossi@fiat.com
Citroen Luca verdi lverdi@citroen.com
Ford Franco Giallo fgiallo@ford.com
Fiat Pluto Pippo ppippo@fiat.com
Fiat Paperini Carlo cpaperini@fiat.com
Risultato che vorrei ottenere
Fiat Paolo rossi prossi@fiat.com Pluto Pippo ppippo@fiat.com Paperini Carlo cpaperini@fiat.com
Citroen Luca verdi lverdi@citroen.com
Ford Franco Giallo fgiallo@ford.com
Excel formattazione condizionaleexcel8/13/2019 12:54 PM by by sal
ripristinare tabella di riempimento con formule, dopo cancellazione righerighe7/24/2019 6:08 PM by saverio1966
Excel formattazioneexcel7/20/2019 5:22 PM by satos
Post: 306
Registered in: 7/11/2015
Age: 29
Senior User
office 2013-2016
OFFLINE
7/29/2019 6:29 PM
 
Modify
 
Delete
 
Quote


Buona Sera

c1 =TESTO.UNISCI(" ";VERO;SE(SINISTRA($A$1:$A$5;RICERCA(" ";$A$1:$A$5)-1)=$M1;$A$1:$A$5;""))

copia in basso


se utilizzi office 365 non devi confermare con

control+shift+enter

se utilizzi office 2019 devi confermare con

control +shift +enter .Office 365 -0ffice 2019 sono solo quelli

con cui potrai lavorare e trasferire il file.



Per fare una formula unica

ho messo in M1,M2,M3 le marche auto

In allegato File


[Edited by Ulisse1990 7/29/2019 6:36 PM]
Post: 4
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/30/2019 8:22 AM
 
Modify
 
Delete
 
Quote

Re:
Ulisse1990, 29/07/2019 18.29:


Buona Sera

c1 =TESTO.UNISCI(" ";VERO;SE(SINISTRA($A$1:$A$5;RICERCA(" ";$A$1:$A$5)-1)=$M1;$A$1:$A$5;""))

copia in basso


se utilizzi office 365 non devi confermare con

control+shift+enter

se utilizzi office 2019 devi confermare con

control +shift +enter .Office 365 -0ffice 2019 sono solo quelli

con cui potrai lavorare e trasferire il file.



Per fare una formula unica

ho messo in M1,M2,M3 le marche auto

In allegato File






Post: 5
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/30/2019 8:23 AM
 
Modify
 
Delete
 
Quote

Re:
ULISSE SEI UN GRANDE
grazie

Ulisse1990, 29/07/2019 18.29:


Buona Sera

c1 =TESTO.UNISCI(" ";VERO;SE(SINISTRA($A$1:$A$5;RICERCA(" ";$A$1:$A$5)-1)=$M1;$A$1:$A$5;""))

copia in basso


se utilizzi office 365 non devi confermare con

control+shift+enter

se utilizzi office 2019 devi confermare con

control +shift +enter .Office 365 -0ffice 2019 sono solo quelli

con cui potrai lavorare e trasferire il file.



Per fare una formula unica

ho messo in M1,M2,M3 le marche auto

In allegato File






Post: 6
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/30/2019 8:50 AM
 
Modify
 
Delete
 
Quote

ciao Ulisse
le colonne Azienda Contatto email sono 3 colonne separate e il risultato dovrà andare il altre colonne separate non in un'unica cella
Post: 371
Registered in: 1/15/2016
Location: ROMA
Age: 46
Senior User
2016
OFFLINE
7/30/2019 9:11 AM
 
Modify
 
Delete
 
Quote

Buongiorno
se alleghi un file con i dati iniziali e il risultato da ottenere scritto a mano è più facile rispondere
Post: 7
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/30/2019 9:40 AM
 
Modify
 
Delete
 
Quote

Re:
DANILOFIORINI, 30/07/2019 09.11:

Buongiorno
se alleghi un file con i dati iniziali e il risultato da ottenere scritto a mano è più facile rispondere



ciao Danilo, allego il file di esempio
Post: 372
Registered in: 1/15/2016
Location: ROMA
Age: 46
Senior User
2016
OFFLINE
7/30/2019 10:22 AM
 
Modify
 
Delete
 
Quote

Ciao

in D12 da trascinare in basso

=SE.ERRORE(INDICE(A$2:A$100;CONFRONTA(0;INDICE(CONTA.SE($D$11:$D11;$A$2:A$100&""););0));"")

in E12 da trascinare a destra e poi in basso

=SE.ERRORE(INDICE($B$2:$C$100;AGGREGA(15;6;RIF.RIGA($A$2:$A$100)/($A$2:$A$100=$D12)-RIF.RIGA($A$2)+1;QUOZIENTE(RIF.COLONNA(A$1)-1;2)+1);RESTO(RIF.COLONNA(A$1)-1;2)+1);"")
Post: 8
Registered in: 5/22/2019
Location: MILANO
Age: 52
Junior User
Office365
OFFLINE
7/30/2019 10:35 AM
 
Modify
 
Delete
 
Quote

Re:
DANILO....CHAPEAU....
Complimenti

DANILOFIORINI, 30/07/2019 10.22:

Ciao

in D12 da trascinare in basso

=SE.ERRORE(INDICE(A$2:A$100;CONFRONTA(0;INDICE(CONTA.SE($D$11:$D11;$A$2:A$100&""););0));"")

in E12 da trascinare a destra e poi in basso

=SE.ERRORE(INDICE($B$2:$C$100;AGGREGA(15;6;RIF.RIGA($A$2:$A$100)/($A$2:$A$100=$D12)-RIF.RIGA($A$2)+1;QUOZIENTE(RIF.COLONNA(A$1)-1;2)+1);RESTO(RIF.COLONNA(A$1)-1;2)+1);"")




Admin Thread: | Close | Move | Delete | Modify | Email Notification Previous page | 1 | Next page
New Thread
 | 
Reply
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Neanderthal Excel (1 post, agg.: 11/12/2018 4:54 PM)
Home Forum | Bacheca | Album | Users | Search | Log In | Register | Admin
Tutti gli orari sono GMT+01:00. Adesso sono le 5:38 AM. : Printable | Mobile | Regolamento | Privacy
FreeForumZone [v.5.0.0] - Copyright © 2000-2019 FFZ srl - www.freeforumzone.com