Previous page | 1 | Next page
Facebook  

Estrarre testo tra caratteri, compresi i caratteri

Last Update: 2/10/2019 3:53 PM
Author
Print | Email Notification    
2/10/2019 11:05 AM
 
Modify
 
Delete
 
Quote

Buongiorno a tutti.

In una cella A1 ho del testo, composto come segue:

aaaaa bbbbbb cccccc [xxxxxxxxxx]

Il numero di parole è variabile e anche la lunghezza delle stesse, inoltre, la parola tra parentesi quadre potrebbe anche non essere presente, ma se c'è è sempre la prima da destra.

Ho bisogno di dividere il testo tra partentesi quadre (se presente) da quello fuori, restituendo il risultato in due celle diverse.

Quindi:
- nella cella A2 ho bisogno che mi restituisca solo il testo che si trova fuori dalle quadre;
- nella cella B2 ho bisogno del testo che si trova tra le quadre, comprese le quadre stesse, ma se non ci fossero le quadre, non mi deve restituire nessun teso.

Grazie a chi mi vorrà aiutare.
[Edited by Fabio Mattana 2/10/2019 12:09 PM]
calcolo prodotto tra due cifre decimalitra6/19/2019 4:53 PM by Konki66
confronto tra numeritra6/22/2019 7:46 AM by Salvatore Vicari
E' giusto adorare Gesù?Testimoni di Geova Online...88 pt.6/25/2019 5:36 AM by Aquila-58
Post: 2,115
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
2/10/2019 11:16 AM
 
Modify
 
Delete
 
Quote

ciao

prova a spiegare cosa dobbiamo fare,

 
Quindi:
- nella cella A2 ho bisogno che mi restituisca solo il testo che si trova fuori dalle quadre;
- nella cella A2 ho bisogno del testo che si trova tra le quadre, comprese le quadre stesse, ma se non ci fossero le quadre, non mi deve restituire nessun teso.


tutto questo va in A2 ???????????

Ciao da locate
excel 2007 / 13
2/10/2019 12:09 PM
 
Modify
 
Delete
 
Quote

Re:
locatevaresino, 10/02/2019 11.16:

ciao

prova a spiegare cosa dobbiamo fare,

 
Quindi:
- nella cella A2 ho bisogno che mi restituisca solo il testo che si trova fuori dalle quadre;
- nella cella A2 ho bisogno del testo che si trova tra le quadre, comprese le quadre stesse, ma se non ci fossero le quadre, non mi deve restituire nessun teso.


tutto questo va in A2 ???????????




No, scusa ho editato il primo post
Post: 13
Registered in: 10/15/2017
Location: SAN VITO AL TORRE
Age: 53
Junior User
Excel online
OFFLINE
2/10/2019 3:38 PM
 
Modify
 
Delete
 
Quote

Ciao per fare quello che chiedi, prova: in A2
=SE(VAL.NUMERO(TROVA("[";A1));STRINGA.ESTRAI(A1;1;TROVA("[";A1)-1);STRINGA.ESTRAI(RIMPIAZZA(A1;LUNGHEZZA(A1);1;"[");1;TROVA("[";RIMPIAZZA(A1;LUNGHEZZA(A1);1;"["))-1))
e in B2
=SE(VAL.NUMERO(TROVA("[";A1));STRINGA.ESTRAI(A1;TROVA("[";A1);100);"")
[Edited by gioheu66 2/10/2019 3:41 PM]
Post: 2,116
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
2/10/2019 3:41 PM
 
Modify
 
Delete
 
Quote

ciao

allora abbiamo capito
in A2 =SE(VAL.NUMERO(TROVA("[";A1));STRINGA.ESTRAI(A1;1;TROVA("[";A1)-1);A1)
in B2 =SE(VAL.NUMERO(TROVA("[";A1));STRINGA.ESTRAI(A1;TROVA("[";A1);50);"")



non avevo calcolato l'errore
[Edited by locatevaresino 2/10/2019 3:47 PM]
Ciao da locate
excel 2007 / 13
Post: 2,117
Registered in: 3/21/2008
Location: LOCATE VARESINO
Age: 71
Veteran User
2007 / 13
OFFLINE
2/10/2019 3:53 PM
 
Modify
 
Delete
 
Quote

riciao

in B2 puoi anche utilizzare DESTRA()
=SE(VAL.NUMERO(TROVA("[";A1));DESTRA(A1;LUNGHEZZA(A1)-TROVA("[";A1)+1);"")
Ciao da locate
excel 2007 / 13
Admin Thread: | Close | Move | Delete | Modify | Email Notification Previous page | 1 | Next page
New Thread
 | 
Reply
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Users | Search | Log In | Register | Admin
Tutti gli orari sono GMT+01:00. Adesso sono le 6:38 AM. : Printable | Mobile | Regolamento | Privacy
FreeForumZone [v.5.0.0] - Copyright © 2000-2019 FFZ srl - www.freeforumzone.com