Pagina precedente | 1 | Pagina successiva
Facebook  

Problema su eliminazione riga

Ultimo Aggiornamento: 08/03/2018 15.19
Autore
Stampa | Notifica email    
Post: 8
Registrato il: 26/02/2016
Città: MILANO
Età: 38
Utente Junior
2010
OFFLINE
08/03/2018 11.12

Ciao a tutti,
vi spiego il problema riscontrato:
Ho un foglio1 dove vado a compilare la cella A2
Sul foglio2 nella cella A10 ho una formula che fa riferiemnto alla cella A2.
Se nel foglio1 cancello la riga A2, nella formula del Foglio2 il riferimento a Foglio1!A2 si tramuta in #RIF.
Vorrei che la formula rimanesse come prima come faccio?
Problema con formatoproblema24/09/2018 11.18 by GianpietroC
Prova eliminazione allegatoTELEGIORNALISTE FANS FORU...eliminazione11/09/2018 11.03 by l'acero
Problema Elettrico???Honda Dominatorproblema22/09/2018 22.52 by CIRODOMINATOR
Post: 3.240
Registrato il: 28/06/2011
Città: BINASCO
Età: 65
Utente Master
2007
OFFLINE
08/03/2018 11.55

Prova bloccando la cella con il $
Ex =SE(Foglio1!A$2=1;111;222), naturale se elimini pure riga2 appare il #RIF.
Per bloccarla definitamente devi usare Indiretto e fare la differenza attuale tra riga10-riga2= 8
=SE(INDIRETTO("Foglio1!A"&RIF.RIGA()-8)=1;111;222)
------------------------------------
Un saluto Excel 2007 (se riesco capire il 2013)
Post: 8
Registrato il: 26/02/2016
Città: MILANO
Età: 38
Utente Junior
2010
OFFLINE
08/03/2018 12.28

Grazie mille ma non capisco...
la prova del $ l'ho già eseguita ma se cancello la riga mi restituisce #RIF.
Riporto le funzioni cosi come sono nei rispettivi fogli:

Sul foglio2 (che si chiama BDP):
=IFERROR(VLOOKUP('Prelievo Materiale'!A$2;Inventario!$A$2:$A$999;1))

Sul Foglio1 (che si chiama Prelievo Materiale)
è riportato un codice alfanumerico (F0103060300015).

Mi spiegheresti la prassi della funzione INDIRETTO da inserire sulla formula.

Post: 3.242
Registrato il: 28/06/2011
Città: BINASCO
Età: 65
Utente Master
2007
OFFLINE
08/03/2018 13.45

Di norma dovresti spiegare per quale motivo devi eliminare una riga + allegare un esempio per provare
Nella Tua mancano alcuni particolari sulla formula, forse? differenza sulle OPZIONI EXCEL?

>>>=IFERROR(VLOOKUP('Prelievo Materiale'!A$2;Inventario!$A$2:$A$999;1))
In Excel=Italiano dovrebbe essere...
=SE.ERRORE(CERCA.VERT('Prelievo Materiale'!A$2;Inventario!$A$2:$A$999;1;FALSO);"")

Nel BDP cella A10 mi risulta >>>F0103060300015 , se aggiungo INDIRETTO
=SE.ERRORE(CERCA.VERT(INDIRETTO("'Prelievo Materiale'!A"&RIF.RIGA()-8);Inventario!$A$2:$A$999;1;FALSO);"")

Ps. Naturale che eliminando una riga, Excel prenderà sempre il valore presente in riga2 (vecchio "ex" valore di riga3)
[Modificato da raffaele1953 08/03/2018 14.00]
------------------------------------
Un saluto Excel 2007 (se riesco capire il 2013)
Post: 9
Registrato il: 26/02/2016
Città: MILANO
Età: 38
Utente Junior
2010
OFFLINE
08/03/2018 14.06

Perfetto funziona...
A me serve appunto che la riga 3 diventi la riga 2 una volta che cancello quest'ultima poichè mi andrà a compilare i campi sul secondo foglio.
Scusami ma mi spiegheresti il concetto della funzione indiretto con rif. riga()-8?
Non mi entra in testa!
Per il mio ragionamento il riferimento è sempre la cella A2, che se viene cancellata e sovrascritta dalla riga 3 il valore su A2 cambia di conseguenza...excel ragiona in un altro modo mi sembra di capire... [SM=x423059]
[Modificato da Stefano.Rescassi 08/03/2018 14.10]
Post: 3.245
Registrato il: 28/06/2011
Città: BINASCO
Età: 65
Utente Master
2007
OFFLINE
08/03/2018 15.19

>>>il concetto della funzione indiretto con rif. riga()-8?
INDIRETTO usa delle stringhe di testo, nel stesso foglio non puoi scrivere =INDIRETTO(A1)
Però puoi scrivere =INDIRETTO("A"&1) >>>&=aggiungi "un numero"
Trà virgolette "il testo accompagnato" +&+ il numero "riga" che scegli
Mi era venuta con >>>rif. riga()-8<<<, ripensandoci sarebbe meglio>>>rif. riga(A$1)+1
Che significa >>>rif. riga(A$1)=1, più uno =riga2
Ps. Attento che se Ti riferisci ad altri fogli potrebbe mancare un particolare
INDIRETTO("'Prelievo ....noti il (') dopo le virgolette.....ed anche qui (Materiale'!A")
------------------------------------
Un saluto Excel 2007 (se riesco capire il 2013)
Amministra Discussione: | Chiudi | Sposta | Cancella | Modifica | Notifica email Pagina precedente | 1 | Pagina successiva
Nuova Discussione
 | 
Rispondi
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Utenti | Cerca | Login | Registrati | Amministra
Tutti gli orari sono GMT+01:00. Adesso sono le 16.27. Versione: Stampabile | Mobile | Regolamento Privacy
FreeForumZone [v.4.4.2] - Copyright © 2000-2018 FFZ srl - www.freeforumzone.com