Pagina precedente | 1 | Pagina successiva
Facebook  

Formula del SE com moltiplicazione

Ultimo Aggiornamento: 06/02/2018 15.42
Autore
Stampa | Notifica email    
Post: 2
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
04/02/2018 16.49

Non ho trovato risposta a questo quesito pertanto ve lo sottopongo...

foglio 1 elenco e quantità di materiali quindi colonna A quantità, colonna B descrizione

ora avrei bisogno che in un altro foglio se in foglio 1 compare la descrizione ad esempio "gas" in foglio due mi riporti il contenute della corrispondente cella...

allego un file con i diversi tentativi fatti da cui ho ottenuto diversi risultati ma nessuno era quello sperato.
Grazie in anticipo...

Formula 1...Voci nel Web...formula03/08/2018 20.29 by Diego.Torme
raduno del sudHonda Dominatordel17/08/2018 21.35 by marcodom
Formulaformula16/08/2018 11.12 by Pierspe
Post: 2.644
Registrato il: 03/04/2013
Utente Veteran
Excel 2000 - 2013
OFFLINE
04/02/2018 19.44

Se ho interpretato correttamente la tua richiesta potresti provare con:
-    Cella "A2" descrizione da valutare
-    Cella "C2"
=Foglio1!$B2 

da copiare nelle Celle sottostanti
-    Cella "D2"
=SE($C2<>$A$2;"-";SCARTO(Foglio1!B2;CONFRONTA($C2;Foglio1!$B2:$B$6;0)-1;-1;1;1)) 

da copiare nelle Celle sottostanti



Giuseppe

Windows XP - Excel 2000
Windows 10 - Excel 2013
Post: 1.523
Registrato il: 10/10/2013
Città: VICENZA
Età: 63
Utente Veteran
excel 2016
OFFLINE
05/02/2018 08.53

ciao

solo per didattica

le tue formule vanno bene
ma devono essere messe sulla stessa riga
della matrice.
questa


=SE(Foglio1!$B$2:$B$6="Gas*";(Foglio1!$A$2:$A$6)*1;"-")



ha un'asterisco in più per quello non funziona

quella in f14 spostala sulla riga 8 e vedi che funziona.

ascolta il consiglio di Giuseppe
o utilizza indice /confronta
[Modificato da federico460 05/02/2018 09.00]
Post: 2
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
05/02/2018 14.09

Grazie per le risposte quindi non ho modo di "riepilogare" su un altro foglio il tutto in una sola volta e in modo completo, ogni volta dovrei scegliere dal menù a tendina cosa voglio sapere?
Trattasi di voci che possono essere inserite senza una logica particolare per cui non avrei modo di sapere dove si trovano (per automatizzare il processo ovviamente)
Provo a studiarmi indice confronta...


edit:
eh sono un po' lento ma alla fine ci arrivo! grazie giuseppe ora vedo come posso sfruttarlo!
[Modificato da oloap25 05/02/2018 14.25]
Post: 2.646
Registrato il: 03/04/2013
Utente Veteran
Excel 2000 - 2013
OFFLINE
05/02/2018 17.11

Buona sera,oloaP;
nei miei test i valori in "Convalida dati" ho gestito solo i Valori univoci:
-   scopa
-   gas
-   estintore
-   guanti
Voglio dire gas, nell'elenco di descrizioni univoche, compare una sola volta anche se nel DataSet è previsto in più Record.
Per fare ciò ho dovuto utilizzare una Colonna d'appoggio; poi, ovviamente, vedi tu.


Giuseppe

Windows XP - Excel 2000
Windows 10 - Excel 2013
Post: 3
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
05/02/2018 21.05

niente non riesco a fare quello che vorrei! allego un altro file questa volta (forse) più chiaro di quello che vorrei riepilogare, in pratica si tratterebbe di una sorta di contabilità e dal mensile avrei bisogno di estrapolare singole voci e poterle contare su di un altro foglio...
Post: 1.527
Registrato il: 10/10/2013
Città: VICENZA
Età: 63
Utente Veteran
excel 2016
OFFLINE
05/02/2018 21.28

ciao
due possibilità

in C7 da tirare in giù


=MATR.SOMMA.PRODOTTO((Tabella19179[[#Tutti];[Colonna2]]=Foglio2!B7)*(Tabella19179[[#Tutti];[Colonna6]]))




=SOMMA.SE(Tabella19179[[#Tutti];[Colonna2]];B7;Tabella19179[[#Tutti];[Colonna6]])



se ti posso dare un consiglio

in B7


=SE.ERRORE(INDICE(Foglio1!$C$2:$C$34;CONFRONTA(0;INDICE(CONTA.SE(F$6:$F6;Foglio1!$C$2:$C$34)/(Foglio1!$C$2:$C$34<>""););0));"")



e tira in giù
ti estrae gli univoci dalla tabella
[Modificato da federico460 05/02/2018 21.39]
Post: 4
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
05/02/2018 21.56

Re:
federico460, 05/02/2018 21.28:

ciao
due possibilità...





Mica ho capito... copiando le formule neppure mi da un messaggio di errore si limita ad ignorare persino il segno dell'uguale e mi riporta la formula come testo, per quanto riguarda il consiglio (l'ultima formula che suggerisci) si limita a ripetere "grasso" se tiro giù...
Post: 1.528
Registrato il: 10/10/2013
Città: VICENZA
Età: 63
Utente Veteran
excel 2016
OFFLINE
05/02/2018 21.59

vedi il file

Post: 1.529
Registrato il: 10/10/2013
Città: VICENZA
Età: 63
Utente Veteran
excel 2016
OFFLINE
05/02/2018 22.04

per le formule
delle volte a me neanche le copia dal forum

fai così

copia la formula incollala sul notes

poi ricopiala e incollala sul file

vedi che funziona

per gli univoci
colpa mia in colonna B va scritto


=SE.ERRORE(INDICE(Foglio1!$C$2:$C$34;CONFRONTA(0;INDICE(CONTA.SE(B$6:$B6;Foglio1!$C$2:$C$34)/(Foglio1!$C$2:$C$34<>""););0));"")



io avevo utilizzato la colonna F
[Modificato da federico460 05/02/2018 22.08]
Post: 2.647
Registrato il: 03/04/2013
Utente Veteran
Excel 2000 - 2013
OFFLINE
05/02/2018 22.29

Buona sera a Tutti;
dopo aver preso buona nota delle soluzioni proposte da @federic0460, che saluto, potresti considerare:

Nel Foglio di lavoro "Foglio2", in Cella "B7":
=SE.ERRORE(INDICE(Tabella19179[[#Tutti];[Colonna3]];CONFRONTA(0;INDICE(CONTA.SE(B$6:B6;Tabella19179[[#Tutti];[Colonna3]]&""););0));"")
da copiare nelle Celle sottostanti.

Nel Foglio di lavoro "Foglio2", in Cella "C7":
=SOMMA.SE(Tabella19179[[#Tutti];[Colonna3]];$B7;Tabella19179[[#Tutti];[Colonna6]])
da copiare nelle Celle sottostanti.



A disposizione.

Buona serata a Tutti.

Giuseppe

Windows XP - Excel 2000
Windows 10 - Excel 2013
Post: 2.649
Registrato il: 03/04/2013
Utente Veteran
Excel 2000 - 2013
OFFLINE
05/02/2018 23.35

Buona sera a Tutti;
vedo solo ora che @federic0460, ha considerato il Campo "Note" mentre io avevo considerato il Campo "Operazione".

In ogni caso allego il File con entrambe le valutazioni.



A disposizione.

Buona serata a Tutti.

Giuseppe

Windows XP - Excel 2000
Windows 10 - Excel 2013
Post: 5
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
06/02/2018 14.04

grazie di cuore ad entrambi per il tempo speso, l'unica formula che funziona è l'ultima di giuseppe quelle di federico anche facendole passare per block notes continuano a visualizzarsi come testo, una curiosità a federico dove trovi il valore "Tabella19179"? perch' anche ricopiando a mano la tua formula (che persisteva nell'essere visualizzata come testo) mi dava dei suggerimenti ma si fermava a 19!
Comnque grazie, grazie e ancora grazie!
Post: 2.654
Registrato il: 03/04/2013
Utente Veteran
Excel 2000 - 2013
OFFLINE
06/02/2018 15.05

Buon pomeriggio, oloaP;
solo per completezza, sei sicuro che le Formule che sembrano non funzionare non vengano copiate in Celle definite come Formato "Testo"?

Dico questo perchè può accadere che una Formula, copiata in una cella definita come Formato "Generale" funziona perfettamente mentre la stessa Formula inserita in una Cella definita come Formato "Testo" in realtà è una stringa e, come tale, non può rendere il risultato della Formula.



Buona serata.

Giuseppe

Windows XP - Excel 2000
Windows 10 - Excel 2013
Post: 6
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
06/02/2018 15.17

No, controllato ora formato generale...
Post: 1.530
Registrato il: 10/10/2013
Città: VICENZA
Età: 63
Utente Veteran
excel 2016
OFFLINE
06/02/2018 15.20

???????
non capisco se hai il 2007 dovrebbe funzionare tutto
ma il mio file ti funziona?

per la =Tabella19179[[#Tutti];[Colonna6]]

prova a scrivere = e seleziona le celle da B2 A B32

e vedi

ti faccio notare che anche Giuseppe nella formula ha
tabella19179 dovuto alla stessa selezione

ma anche copiandola dal file ti viene come testo?
[Modificato da federico460 06/02/2018 15.25]
Post: 7
Registrato il: 04/02/2018
Età: 49
Utente Junior
2007
OFFLINE
06/02/2018 15.42

Re:
federico460, 06/02/2018 15.20:

???????
non capisco se hai il 2007 dovrebbe funzionare tutto
ma il mio file ti funziona?



Si il tuo file funziona, potrebbe essere qualche impostazione che inavvertitamente ho dato al file?



per la =Tabella19179[[#Tutti];[Colonna6]]

prova a scrivere = e seleziona le celle da B2 A B32

e vedi



Ah! Forte!!!



ti faccio notare che anche Giuseppe nella formula ha
tabella19179 dovuto alla stessa selezione



Infatti la formula che funziona è il secondo invio in pratica quello con la formula del SE con riferimenti classici



ma anche copiandola dal file ti viene come testo?



l'ho persino trascritta manualemente come se la stessi creando io ma nulla me la visualizza come fosse testo, non solo la prima ma anche l'altra e pure quella di giuseppe (la prima non qualla che funziona)




Amministra Discussione: | Chiudi | Sposta | Cancella | Modifica | Notifica email Pagina precedente | 1 | Pagina successiva
Nuova Discussione
 | 
Rispondi
Cerca nel forum
Tag discussione
Discussioni Simili   [vedi tutte]
Home Forum | Bacheca | Album | Utenti | Cerca | Login | Registrati | Amministra
Tutti gli orari sono GMT+01:00. Adesso sono le 19.45. Versione: Stampabile | Mobile | Regolamento Privacy
FreeForumZone [v.4.4.2] - Copyright © 2000-2018 FFZ srl - www.freeforumzone.com